In short
- CVE-2024-42473 is a CRITICAL (CVSS 9.8) vulnerability affecting github.com/openfga/openfga, openfga (openfga).
- Chance of exploitation in the next 30 days (EPSS): 0.53%, higher than 44.6% of all vulnerabilities.
- Fix: update to 1.5.9 or later.
Description
Overview
OpenFGA v1.5.7 and v1.5.8 are vulnerable to authorization bypass when calling Check API with a model that uses but not and from expressions and a userset.
Fix
- If you are using OpenFGA within Docker or as a Go library, as a binary, or through Docker, upgrade to v1.5.9 as soon as possible
- If using Helm chart, upgrade to 0.2.12 as soon as possible.
This fix is backward compatible.
NVD description
OpenFGA is an authorization/permission engine. OpenFGA v1.5.7 and v1.5.8 are vulnerable to authorization bypass when calling Check API with a model that uses `but not` and `from` expressions and a userset. Users should downgrade to v1.5.6 as soon as possible. This downgrade is backward compatible. As of time of publication, a patch is not available but OpenFGA's maintainers are planning a patch for inclusion in a future release.
More vulnerabilities in github.com/openfga/openfga
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free