In short
- CVE-2024-43799 is a MEDIUM (CVSS 4.7) vulnerability affecting send (send project), send.
- Chance of exploitation in the next 30 days (EPSS): 0.54%, higher than 45.5% of all vulnerabilities.
- Fix: update to 0.19.0 or later.
| Package | Affected versions | Patched versions |
|---|
| send | < 0.19.0
| 0.19.0
|
| send npm | < 0.19.0
| 0.19.0
|
Description
Impact
passing untrusted user input - even after sanitizing it - to SendStream.redirect() may execute untrusted code
Patches
this issue is patched in send 0.19.0
Workarounds
users are encouraged to upgrade to the patched version of express, but otherwise can workaround this issue by making sure any untrusted inputs are safe, ideally by validating them against an explicit allowlist
Details
successful exploitation of this vector requires the following:
- The attacker MUST control the input to response.redirect()
- express MUST NOT redirect before the template appears
- the browser MUST NOT complete redirection before:
- the user MUST click on the link in the template
NVD description
Send is a library for streaming files from the file system as a http response. Send passes untrusted user input to SendStream.redirect() which executes untrusted code. This issue is patched in send 0.19.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free