In short
- CVE-2024-44625 is a HIGH (CVSS 8.8) vulnerability affecting gogs.io/gogs, gogs (gogs).
- Chance of exploitation in the next 30 days (EPSS): 16.5%, higher than 97.0% of all vulnerabilities.
- Fix: update to 0.13.2 or later.
| Package | Affected versions | Patched versions |
|---|
| gogs.io/gogs Go | < 0.13.2all versions
| 0.13.2
|
| gogs | ≤ 0.13.0
| No fix yet |
Description
Gogs <0.13.2 is vulnerable to symbolic link path traversal that enables remote code execution via the editFilePost function of internal/route/repo/editor.go.
NVD description
Gogs <=0.13.0 is vulnerable to Directory Traversal via the editFilePost function of internal/route/repo/editor.go.
More vulnerabilities in gogs.io/gogs
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free