| Package | Affected versions | Patched versions |
|---|---|---|
| github.com/apache/trafficcontrol | all versions | |
| github.com/apache/trafficcontrol/v8 | ≥ 8.0.0, < 8.0.2 | 8.0.2 |
| traffic control | ≥ 8.0.0, < 8.0.2 | 8.0.2 |
An SQL injection vulnerability in Traffic Ops in Apache Traffic Control <= 8.0.1, >= 8.0.0 allows a privileged user with role "admin", "federation", "operations", "portal", or "steering" to execute arbitrary SQL against the database by sending a specially-crafted PUT request.
Users are recommended to upgrade to version Apache Traffic Control 8.0.2 if you run an affected version of Traffic Ops.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free