In short
- CVE-2024-45601 is a HIGH (CVSS 7.5) vulnerability affecting mesop.
- Chance of exploitation in the next 30 days (EPSS): 0.28%, higher than 20.5% of all vulnerabilities.
- Fix: update to 0.12.4 or later.
| Package | Affected versions | Patched versions |
|---|
| mesop PyPI | ≥ 0.9.0, < 0.12.4
| 0.12.4
|
Description
A vulnerability has been discovered and fixed in Mesop that could potentially allow unauthorized access to files on the server hosting the Mesop application. The vulnerability was related to insufficient input validation in a specific endpoint. This could have allowed an attacker to access files not intended to be served.
Users are strongly advised to update to the latest version of Mesop immediately. The latest version includes a fix for this vulnerability.
We would like to thank @Letm3through for reporting this issue and proposing mitigations to address this issue.
NVD description
Mesop is a Python-based UI framework designed for rapid web apps development. A vulnerability has been discovered and fixed in Mesop that could potentially allow unauthorized access to files on the server hosting the Mesop application. The vulnerability was related to insufficient input validation in a specific endpoint. This could have allowed an attacker to access files not intended to be served. Users are strongly advised to update to the latest version of Mesop immediately. The latest version includes a fix for this vulnerability. At time of publication 0.12.4 is the most recently available version of Mesop.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free