In short
- CVE-2024-45719 is a LOW (CVSS 2.6) vulnerability affecting github.com/apache/incubator-answer, answer (apache).
- Chance of exploitation in the next 30 days (EPSS): 0.26%, higher than 18.2% of all vulnerabilities.
- Fix: update to 1.4.1 or later.
Description
Inadequate Encryption Strength vulnerability in Apache Answer.
This issue affects Apache Answer: through 1.4.0.
The ids generated using the UUID v1 version are to some extent not secure enough. It can cause the generated token to be predictable.
Users are recommended to upgrade to version 1.4.1, which fixes the issue.
NVD description
Inadequate Encryption Strength vulnerability in Apache Answer.
This issue affects Apache Answer: through 1.4.0.
The ids generated using the UUID v1 version are to some extent not secure enough. It can cause the generated token to be predictable.
Users are recommended to upgrade to version 1.4.1, which fixes the issue.
More vulnerabilities in github.com/apache/incubator-answer
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free