In short
- CVE-2024-45850 is a HIGH (CVSS 8.8) vulnerability affecting mindsdb, mindsdb (mindsdb).
- Chance of exploitation in the next 30 days (EPSS): 0.87%, higher than 58.9% of all vulnerabilities.
- Fix: update to 24.7.4.1 or later.
| Package | Affected versions | Patched versions |
|---|
| mindsdb PyPI | ≥ 23.10.5.0, < 24.7.4.1
| 24.7.4.1
|
| mindsdb | ≥ 23.10.5.0, < 24.7.4.1
| 24.7.4.1
|
Description
An arbitrary code execution vulnerability exists in versions 23.10.5.0 up to 24.7.4.1 of the MindsDB platform, when the Microsoft SharePoint integration is installed on the server. For databases created with the SharePoint engine, an ‘INSERT’ query can be used for site column creation. If such a query is specially crafted to contain Python code and is run against the database, the code will be passed to an eval function and executed on the server.
NVD description
An arbitrary code execution vulnerability exists in versions 23.10.5.0 up to 24.7.4.1 of the MindsDB platform, when the Microsoft SharePoint integration is installed on the server. For databases created with the SharePoint engine, an ‘INSERT’ query can be used for site column creation. If such a query is specially crafted to contain Python code and is run against the database, the code will be passed to an eval function and executed on the server.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free