In short
- CVE-2024-46957 is a CRITICAL (CVSS 9.8) vulnerability affecting mellium.im/xmpp.
- Chance of exploitation in the next 30 days (EPSS): 0.61%, higher than 49.5% of all vulnerabilities.
- Fix: update to 0.22.0 or later.
Description
Mellium mellium.im/xmpp 0.0.1 through 0.21.4 allows response spoofing because the stanza type is not checked. This is fixed in 0.22.0.
NVD description
Mellium mellium.im/xmpp 0.0.1 through 0.21.4 allows response spoofing if the implementation uses predictable IDs because the stanza type is not checked. This is fixed in 0.22.0.
More vulnerabilities in mellium.im/xmpp
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free