In short
- CVE-2024-46990 is a MEDIUM (CVSS 5.0) vulnerability affecting directus (monospace), @directus/api, directus.
- Chance of exploitation in the next 30 days (EPSS): 0.47%, higher than 40.5% of all vulnerabilities.
- Fix: update to 11.1.0, 10.13.3, 22.1.1, 21.0.0 or later.
| Package | Affected versions | Patched versions |
|---|
| directus | ≥ 11.0.0, < 11.1.0< 10.13.3
| 11.1.010.13.3
|
| @directus/api npm | ≥ 22.0.0, < 22.1.1< 21.0.0
| 22.1.121.0.0
|
| directus npm | ≥ 11.0.0, < 11.1.0< 10.13.3
| 11.1.010.13.3
|
Description
Impact
If you're relying on blocking access to localhost using the default 0.0.0.0 filter this can be bypassed using other registered loopback devices (like 127.0.0.2 - 127.127.127.127)
Workaround
You can block this bypass by manually adding the 127.0.0.0/8 CIDR range which will block access to any 127.X.X.X ip instead of just 127.0.0.1.
NVD description
Directus is a real-time API and App dashboard for managing SQL database content. When relying on blocking access to localhost using the default `0.0.0.0` filter a user may bypass this block by using other registered loopback devices (like `127.0.0.2` - `127.127.127.127`). This issue has been addressed in release versions 10.13.3 and 11.1.0. Users are advised to upgrade. Users unable to upgrade may block this bypass by manually adding the `127.0.0.0/8` CIDR range which will block access to any `127.X.X.X` ip instead of just `127.0.0.1`.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free