In short
- CVE-2024-47178 is a MEDIUM (CVSS 5.3) vulnerability affecting basic-auth-connect (expressjs), basic-auth-connect.
- Chance of exploitation in the next 30 days (EPSS): 0.52%, higher than 44.4% of all vulnerabilities.
- Fix: update to 1.1.0 or later.
Description
Impact
basic-auth-connect <1.1.0 uses a timing-unsafe equality comparison that can leak timing information
Patches
this issue has been fixed in basic-auth-connect 1.1.0
References
NVD description
basic-auth-connect is Connect's Basic Auth middleware in its own module. basic-auth-connect < 1.1.0 uses a timing-unsafe equality comparison that can leak timing information. This issue has been fixed in basic-auth-connect 1.1.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free