In short
- CVE-2024-47183 is a HIGH (CVSS 8.1) vulnerability affecting parse-server (parseplatform), parse-server.
- Chance of exploitation in the next 30 days (EPSS): 0.42%, higher than 36.0% of all vulnerabilities.
- Fix: update to 7.3.0, 6.5.9 or later.
| Package | Affected versions | Patched versions |
|---|
| parse-server | ≥ 7.0.0, < 7.3.0< 6.5.9
| 7.3.06.5.9
|
| parse-server npm | ≥ 7.0.0, < 7.3.0< 6.5.9
| 7.3.06.5.9
|
Description
Impact
If the Parse Server option allowCustomObjectId: true is set, an attacker that is allowed to create a new user can set a custom object ID for that new user that exploits the vulnerability and acquires privileges of a specific role.
Patches
Improved validation for custom user object IDs. Session tokens for existing users with an object ID that exploits the vulnerability are now rejected.
Workarounds
- Disable custom object IDs by setting
allowCustomObjectId: false or not setting the option which defaults to false.
- Use a Cloud Code Trigger to validate that a new user's object ID doesn't start with the prefix
role:.
References
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. If the Parse Server option allowCustomObjectId: true is set, an attacker that is allowed to create a new user can set a custom object ID for that new user that exploits the vulnerability and acquires privileges of a specific role. This vulnerability is fixed in 6.5.9 and 7.3.0.
More vulnerabilities in parse-server
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free