In short
- CVE-2024-47552 is a CRITICAL (CVSS 9.8) vulnerability affecting org.apache.seata:seata-config-core, seata (apache).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 69.3% of all vulnerabilities.
- Fix: update to 2.2.0 or later.
Description
Deserialization of Untrusted Data vulnerability in Apache Seata (incubating).
This issue affects Apache Seata (incubating): from 2.0.0 before 2.2.0.
Users are recommended to upgrade to version 2.2.0, which fixes the issue.
NVD description
Deserialization of Untrusted Data vulnerability in Apache Seata (incubating).
This issue affects Apache Seata (incubating): from 2.0.0 before 2.2.0.
Severity Justification:
The Apache Seata security team assesses the severity of this vulnerability as "Low" due to stringent real-world mitigating factors. First, the vulnerability is strictly isolated to the Raft cluster mode, an optional and non-default feature introduced in v2.0.0, while most users rely on the unaffected traditional architecture. Second, Seata is an internal middleware; communication between TC and RM/TM occurs entirely within trusted internal networks. An attacker would require prior, unauthorized access to the Intranet to exploit this, making external exploitation highly improbable.
Users are recommended to upgrade to version 2.2.0, which fixes the issue.
More vulnerabilities in org.apache.seata:seata-config-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free