In short
- CVE-2024-51752 is a MEDIUM (CVSS 5.5) vulnerability affecting authkit-nextjs (workos), @workos-inc/authkit-nextjs.
- Chance of exploitation in the next 30 days (EPSS): 0.25%, higher than 15.9% of all vulnerabilities.
- Fix: update to 0.13.2 or later.
Description
NVD description
The AuthKit library for Next.js provides convenient helpers for authentication and session management using WorkOS & AuthKit with Next.js. In affected versions refresh tokens are logged to the console when the disabled by default `debug` flag, is enabled. This issue has been patched in version 0.13.2 and all users are advised to upgrade. There are no known workarounds for this vulnerability.
More vulnerabilities in authkit-nextjs
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free