In short
- CVE-2024-51757 is a CRITICAL (CVSS 9.3) vulnerability affecting happy-dom.
- Chance of exploitation in the next 30 days (EPSS): 0.77%, higher than 55.7% of all vulnerabilities.
- Fix: update to 15.10.2 or later.
| Package | Affected versions | Patched versions |
|---|
| happy-dom npm | < 15.10.2
| 15.10.2
|
Description
Impact
Consumers of the NPM package happy-dom
Patches
The security vulnerability has been patched in v15.10.2
Workarounds
No easy workarounds to my knowledge
References
#1585
NVD description
happy-dom is a JavaScript implementation of a web browser without its graphical user interface. Versions of happy-dom prior to 15.10.2 may execute code on the host via a script tag. This would execute code in the user context of happy-dom. Users are advised to upgrade to version 15.10.2. There are no known workarounds for this vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free