In short
- CVE-2024-52304 is a HIGH (CVSS 7.5) vulnerability affecting aiohttp, aiohttp (aiohttp).
- Chance of exploitation in the next 30 days (EPSS): 0.56%, higher than 46.8% of all vulnerabilities.
- Fix: update to 3.10.11 or later.
| Package | Affected versions | Patched versions |
|---|
| aiohttp PyPI | < 3.10.11
| 3.10.11
|
| aiohttp | < 3.10.11
| 3.10.11
|
Description
Summary
The Python parser parses newlines in chunk extensions incorrectly which can lead to request smuggling vulnerabilities under certain conditions.
Impact
If a pure Python version of aiohttp is installed (i.e. without the usual C extensions) or AIOHTTP_NO_EXTENSIONS is enabled, then an attacker may be able to execute a request smuggling attack to bypass certain firewalls or proxy protections.
Patch: https://github.com/aio-libs/aiohttp/commit/259edc369075de63e6f3a4eaade058c62af0df71
NVD description
aiohttp is an asynchronous HTTP client/server framework for asyncio and Python. Prior to version 3.10.11, the Python parser parses newlines in chunk extensions incorrectly which can lead to request smuggling vulnerabilities under certain conditions. If a pure Python version of aiohttp is installed (i.e. without the usual C extensions) or `AIOHTTP_NO_EXTENSIONS` is enabled, then an attacker may be able to execute a request smuggling attack to bypass certain firewalls or proxy protections. Version 3.10.11 fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free