| Package | Affected versions | Patched versions |
|---|---|---|
| nextcloud server | ≥ 25.0.0, < 25.0.13.14≥ 26.0.0, < 26.0.13.10≥ 27.0.0, < 27.1.11.10≥ 28.0.0, < 28.0.12≥ 29.0.0, < 29.0.9≥ 30.0.0, < 30.0.2 | 25.0.13.1426.0.13.1027.1.11.1028.0.1229.0.930.0.2 |
Nextcloud Server is a self hosted personal cloud system. After setting up a user or administrator defined external storage with fixed credentials, the API returns them and adds them into the frontend again, allowing to read them in plain text when an attacker already has access to an active session of a user. It is recommended that the Nextcloud Server is upgraded to 28.0.12, 29.0.9 or 30.0.2 and Nextcloud Enterprise Server is upgraded to 25.0.13.14, 26.0.13.10, 27.1.11.10, 28.0.12, 29.0.9 or 30.0.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free