In short
- CVE-2024-53382 is a MEDIUM (CVSS 5.4) vulnerability affecting prism (prismjs), prismjs.
- Chance of exploitation in the next 30 days (EPSS): 0.34%, higher than 27.7% of all vulnerabilities.
- Fix: update to 1.30.0 or later.
| Package | Affected versions | Patched versions |
|---|
| prism | ≤ 1.29.0
| No fix yet |
| prismjs npm | < 1.30.0
| 1.30.0
|
Description
Prism (aka PrismJS) through 1.29.0 allows DOM Clobbering (with resultant XSS for untrusted input that contains HTML but does not directly contain JavaScript), because document.currentScript lookup can be shadowed by attacker-injected HTML elements.
NVD description
Prism (aka PrismJS) through 1.29.0 allows DOM Clobbering (with resultant XSS for untrusted input that contains HTML but does not directly contain JavaScript), because document.currentScript lookup can be shadowed by attacker-injected HTML elements.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free