In short
- CVE-2024-53457 is a MEDIUM (CVSS 5.4) vulnerability affecting librenms/librenms, librenms (librenms).
- Chance of exploitation in the next 30 days (EPSS): 46.4%, higher than 98.8% of all vulnerabilities.
- Fix: update to 24.11.0 or later.
| Package | Affected versions | Patched versions |
|---|
| librenms/librenms Packagist | ≥ 24.9.0, < 24.11.0
| 24.11.0
|
| librenms | ≥ 24.9.0, ≤ 24.10.0
| No fix yet |
Description
A stored cross-site scripting (XSS) vulnerability in the Device Settings section of LibreNMS v24.9.0 to v24.10.0 allows attackers to execute arbitrary web scripts or HTML via a crafted payload injected into the Display Name parameter.
NVD description
A stored cross-site scripting (XSS) vulnerability in the Device Settings section of LibreNMS v24.9.0 to v24.10.0 allows attackers to execute arbitrary web scripts or HTML via a crafted payload injected into the Display Name parameter.
More vulnerabilities in librenms/librenms
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free