In short
- CVE-2024-5710 is a MEDIUM (CVSS 6.5) vulnerability affecting litellm, litellm (litellm).
- Chance of exploitation in the next 30 days (EPSS): 0.41%, higher than 34.9% of all vulnerabilities.
- Fix: update to 1.40.15 or later.
| Package | Affected versions | Patched versions |
|---|
| litellm PyPI | < 1.40.15
| 1.40.15
|
| litellm | = 1.34.34
| No fix yet |
Description
berriai/litellm version 1.34.34 is vulnerable to improper access control in its team management functionality. This vulnerability allows attackers to perform unauthorized actions such as creating, updating, viewing, deleting, blocking, and unblocking any teams, as well as adding or deleting any member to or from any teams. The vulnerability stems from insufficient access control checks in various team management endpoints, enabling attackers to exploit these functionalities without proper authorization.
NVD description
berriai/litellm version 1.34.34 is vulnerable to improper access control in its team management functionality. This vulnerability allows attackers to perform unauthorized actions such as creating, updating, viewing, deleting, blocking, and unblocking any teams, as well as adding or deleting any member to or from any teams. The vulnerability stems from insufficient access control checks in various team management endpoints, enabling attackers to exploit these functionalities without proper authorization.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free