In short
- CVE-2024-5751 is a CRITICAL (CVSS 9.8) vulnerability affecting litellm, litellm (litellm).
- Chance of exploitation in the next 30 days (EPSS): 0.88%, higher than 59.2% of all vulnerabilities.
- Fix: update to 1.40.16 or later.
| Package | Affected versions | Patched versions |
|---|
| litellm PyPI | < 1.40.16
| 1.40.16
|
| litellm | = 1.35.8
| No fix yet |
Description
BerriAI/litellm version v1.35.8 contains a vulnerability where an attacker can achieve remote code execution. The vulnerability exists in the add_deployment function, which decodes and decrypts environment variables from base64 and assigns them to os.environ. An attacker can exploit this by sending a malicious payload to the /config/update endpoint, which is then processed and executed by the server when the get_secret function is triggered. This requires the server to use Google KMS and a database to store a model.
NVD description
BerriAI/litellm version v1.35.8 contains a vulnerability where an attacker can achieve remote code execution. The vulnerability exists in the `add_deployment` function, which decodes and decrypts environment variables from base64 and assigns them to `os.environ`. An attacker can exploit this by sending a malicious payload to the `/config/update` endpoint, which is then processed and executed by the server when the `get_secret` function is triggered. This requires the server to use Google KMS and a database to store a model.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free