In short
- CVE-2024-6825 is a HIGH (CVSS 8.8) vulnerability affecting litellm, litellm (litellm).
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 76.5% of all vulnerabilities.
- Fix: update to 1.65.4 or later.
| Package | Affected versions | Patched versions |
|---|
| litellm PyPI | ≥ 1.40.3.dev2, ≤ 1.40.12
| No fix yet |
| litellm | = 1.65.4< 1.65.4
| 1.65.4
|
Description
BerriAI/litellm version 1.40.12 contains a vulnerability that allows remote code execution. The issue exists in the handling of the 'post_call_rules' configuration, where a callback function can be added. The provided value is split at the final '.' mark, with the last part considered the function name and the remaining part appended with the '.py' extension and imported. This allows an attacker to set a system method, such as 'os.system', as a callback, enabling the execution of arbitrary commands when a chat response is processed.
NVD description
BerriAI/litellm version 1.40.12 contains a vulnerability that allows remote code execution. The issue exists in the handling of the 'post_call_rules' configuration, where a callback function can be added. The provided value is split at the final '.' mark, with the last part considered the function name and the remaining part appended with the '.py' extension and imported. This allows an attacker to set a system method, such as 'os.system', as a callback, enabling the execution of arbitrary commands when a chat response is processed.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free