In short
- CVE-2024-6827 is a HIGH (CVSS 7.5) vulnerability affecting gunicorn.
- Chance of exploitation in the next 30 days (EPSS): 0.81%, higher than 57.0% of all vulnerabilities.
- Fix: update to 22.0.0 or later.
| Package | Affected versions | Patched versions |
|---|
| gunicorn PyPI | < 22.0.0
| 22.0.0
|
Description
Gunicorn version 21.2.0 does not properly validate the value of the 'Transfer-Encoding' header as specified in the RFC standards, which leads to the default fallback method of 'Content-Length,' making it vulnerable to TE.CL request smuggling. This vulnerability can lead to cache poisoning, data exposure, session manipulation, SSRF, XSS, DoS, data integrity compromise, security bypass, information leakage, and business logic abuse.
NVD description
Gunicorn version 21.2.0 does not properly validate the value of the 'Transfer-Encoding' header as specified in the RFC standards, which leads to the default fallback method of 'Content-Length,' making it vulnerable to TE.CL request smuggling. This vulnerability can lead to cache poisoning, data exposure, session manipulation, SSRF, XSS, DoS, data integrity compromise, security bypass, information leakage, and business logic abuse.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free