In short
- CVE-2024-7774 is a CRITICAL (CVSS 9.1) vulnerability affecting langchain.js (langchain), langchain.
- Chance of exploitation in the next 30 days (EPSS): 0.56%, higher than 46.4% of all vulnerabilities.
- Fix: update to 0.2.19 or later.
Description
A path traversal vulnerability exists in the getFullPath method of langchain-ai/langchainjs version 0.2.5. This vulnerability allows attackers to save files anywhere in the filesystem, overwrite existing text files, read .txt files, and delete files. The vulnerability is exploited through the setFileContent, getParsedFile, and mdelete methods, which do not properly sanitize user input.
NVD description
A path traversal vulnerability exists in the `getFullPath` method of langchain-ai/langchainjs version 0.2.5. This vulnerability allows attackers to save files anywhere in the filesystem, overwrite existing text files, read `.txt` files, and delete files. The vulnerability is exploited through the `setFileContent`, `getParsedFile`, and `mdelete` methods, which do not properly sanitize user input.
More vulnerabilities in langchain.js
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free