In short
- CVE-2024-7776 is a CRITICAL (CVSS 9.1) vulnerability affecting onnx, onnx (onnx).
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 74.8% of all vulnerabilities.
- Fix: update to 1.16.2, 1.17.0 or later.
| Package | Affected versions | Patched versions |
|---|
| onnx PyPI | < 1.16.2< 1.17.0
| 1.16.21.17.0
|
| onnx | ≤ 1.16.1
| No fix yet |
Description
A vulnerability in the download_model function of the onnx/onnx framework, before and including version 1.16.1, allows for arbitrary file overwrite due to inadequate prevention of path traversal attacks in malicious tar files. This vulnerability can be exploited by an attacker to overwrite files in the user's directory, potentially leading to remote command execution.
NVD description
A vulnerability in the `download_model` function of the onnx/onnx framework, before and including version 1.16.1, allows for arbitrary file overwrite due to inadequate prevention of path traversal attacks in malicious tar files. This vulnerability can be exploited by an attacker to overwrite files in the user's directory, potentially leading to remote command execution.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free