In short
- CVE-2024-7983 is a HIGH (CVSS 7.5) vulnerability affecting open-webui, open webui (openwebui).
- Chance of exploitation in the next 30 days (EPSS): 0.88%, higher than 59.0% of all vulnerabilities.
- Fix: update to 0.5.13 or later.
| Package | Affected versions | Patched versions |
|---|
| open-webui PyPI | ≤ 0.3.8< 0.5.13
| 0.5.13
|
| open webui | = 0.3.8
| No fix yet |
Description
In version 0.3.8 of open-webui, an endpoint for converting markdown to HTML is exposed without authentication. A maliciously crafted markdown payload can cause the server to spend excessive time converting it, leading to a denial of service. The server becomes unresponsive to other requests until the conversion is complete.
NVD description
In version 0.3.8 of open-webui, an endpoint for converting markdown to HTML is exposed without authentication. A maliciously crafted markdown payload can cause the server to spend excessive time converting it, leading to a denial of service. The server becomes unresponsive to other requests until the conversion is complete.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free