In short
- CVE-2024-8053 is a HIGH (CVSS 8.2) vulnerability affecting open-webui, open webui (openwebui).
- Chance of exploitation in the next 30 days (EPSS): 0.65%, higher than 51.2% of all vulnerabilities.
- Fix: update to 0.5.13 or later.
| Package | Affected versions | Patched versions |
|---|
| open-webui PyPI | ≤ 0.3.10< 0.5.13
| 0.5.13
|
| open webui | = 0.3.10
| No fix yet |
Description
In version v0.3.10 of open-webui/open-webui, the api/v1/utils/pdf endpoint lacks authentication mechanisms, allowing unauthenticated attackers to access the PDF generation service. This vulnerability can be exploited by sending a POST request with an excessively large payload, potentially leading to server resource exhaustion and denial of service (DoS). Additionally, unauthorized users can misuse the endpoint to generate PDFs without verification, resulting in service misuse and potential operational and financial impacts.
NVD description
In version v0.3.10 of open-webui/open-webui, the `api/v1/utils/pdf` endpoint lacks authentication mechanisms, allowing unauthenticated attackers to access the PDF generation service. This vulnerability can be exploited by sending a POST request with an excessively large payload, potentially leading to server resource exhaustion and denial of service (DoS). Additionally, unauthorized users can misuse the endpoint to generate PDFs without verification, resulting in service misuse and potential operational and financial impacts.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free