In short
- CVE-2024-8113 is a MEDIUM (CVSS 5.4) vulnerability affecting pretix, pretix (pretix).
- Chance of exploitation in the next 30 days (EPSS): 0.32%, higher than 25.6% of all vulnerabilities.
- Fix: update to 2024.7.1 or later.
| Package | Affected versions | Patched versions |
|---|
| pretix PyPI | < 2024.7.1
| 2024.7.1
|
| pretix | ≤ 2024.7.0
| No fix yet |
Description
Stored XSS in organizer and event settings of pretix up to 2024.7.0 allows malicious event organizers to inject HTML tags into e-mail previews on settings page. The default Content Security Policy of pretix prevents execution of attacker-provided scripts, making exploitation unlikely. However, combined with a CSP bypass (which is not currently known) the vulnerability could be used to impersonate other organizers or staff users.
NVD description
Stored XSS in organizer and event settings of pretix up to 2024.7.0 allows malicious event organizers to inject HTML tags into e-mail previews on settings page. The default Content Security Policy of pretix prevents execution of attacker-provided scripts, making exploitation unlikely. However, combined with a CSP bypass (which is not currently known) the vulnerability could be used to impersonate other organizers or staff users.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free