In short
- CVE-2024-8859 is a HIGH (CVSS 7.5) vulnerability affecting mlflow, mlflow (lfprojects).
- Chance of exploitation in the next 30 days (EPSS): 2.8%, higher than 86.3% of all vulnerabilities.
- Fix: update to 2.17.0rc0 or later.
| Package | Affected versions | Patched versions |
|---|
| mlflow PyPI | < 2.17.0rc0
| 2.17.0rc0
|
| mlflow | = 2.15.1
| No fix yet |
Description
A path traversal vulnerability exists in mlflow/mlflow version 2.15.1. When users configure and use the dbfs service, concatenating the URL directly into the file protocol results in an arbitrary file read vulnerability. This issue occurs because only the path part of the URL is checked, while parts such as query and parameters are not handled. The vulnerability is triggered if the user has configured the dbfs service, and during usage, the service is mounted to a local directory.
NVD description
A path traversal vulnerability exists in mlflow/mlflow version 2.15.1. When users configure and use the dbfs service, concatenating the URL directly into the file protocol results in an arbitrary file read vulnerability. This issue occurs because only the path part of the URL is checked, while parts such as query and parameters are not handled. The vulnerability is triggered if the user has configured the dbfs service, and during usage, the service is mounted to a local directory.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free