In short
- CVE-2024-8984 is a HIGH (CVSS 7.5) vulnerability affecting litellm, litellm (litellm).
- Chance of exploitation in the next 30 days (EPSS): 0.86%, higher than 58.4% of all vulnerabilities.
- Fix: update to 1.56.2, 1.65.4 or later.
| Package | Affected versions | Patched versions |
|---|
| litellm PyPI | < 1.56.2
| 1.56.2
|
| litellm | = 1.65.4< 1.65.4
| 1.65.4
|
Description
A Denial of Service (DoS) vulnerability exists in berriai/litellm version v1.44.5. This vulnerability can be exploited by appending characters, such as dashes (-), to the end of a multipart boundary in an HTTP request. The server continuously processes each character, leading to excessive resource consumption and rendering the service unavailable. The issue is unauthenticated and does not require any user interaction, impacting all users of the service.
NVD description
A Denial of Service (DoS) vulnerability exists in berriai/litellm version v1.44.5. This vulnerability can be exploited by appending characters, such as dashes (-), to the end of a multipart boundary in an HTTP request. The server continuously processes each character, leading to excessive resource consumption and rendering the service unavailable. The issue is unauthenticated and does not require any user interaction, impacting all users of the service.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free