In short
- CVE-2024-9606 is a HIGH (CVSS 7.5) vulnerability affecting litellm, litellm (litellm).
- Chance of exploitation in the next 30 days (EPSS): 0.77%, higher than 55.5% of all vulnerabilities.
- Fix: update to 1.44.12 or later.
| Package | Affected versions | Patched versions |
|---|
| litellm PyPI | < 1.44.12
| 1.44.12
|
| litellm | < 1.44.12
| 1.44.12
|
Description
In berriai/litellm before version 1.44.12, the litellm/litellm_core_utils/litellm_logging.py file contains a vulnerability where the API key masking code only masks the first 5 characters of the key. This results in the leakage of almost the entire API key in the logs, exposing a significant amount of the secret key. The issue affects version v1.44.9.
NVD description
In berriai/litellm before version 1.44.12, the `litellm/litellm_core_utils/litellm_logging.py` file contains a vulnerability where the API key masking code only masks the first 5 characters of the key. This results in the leakage of almost the entire API key in the logs, exposing a significant amount of the secret key. The issue affects version v1.44.9.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free