In short
- CVE-2025-0520 is a CRITICAL (CVSS 9.4) vulnerability affecting showdoc/showdoc.
- Chance of exploitation in the next 30 days (EPSS): 2.4%, higher than 84.3% of all vulnerabilities.
- Fix: update to 2.8.7 or later.
| Package | Affected versions | Patched versions |
|---|
| showdoc/showdoc Packagist | < 2.8.7
| 2.8.7
|
Description
An unrestricted file upload vulnerability in ShowDoc caused by improper validation of file extension allows execution of arbitrary PHP, leading to remote code execution. This issue affects ShowDoc: before 2.8.7.
NVD description
An unrestricted file upload vulnerability in ShowDoc caused by improper validation of file extension allows execution of arbitrary PHP, leading to remote code execution.This issue affects ShowDoc: before 2.8.7.
More vulnerabilities in showdoc/showdoc
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free