In short
- CVE-2025-0628 is a HIGH (CVSS 8.1) vulnerability affecting litellm.
- Chance of exploitation in the next 30 days (EPSS): 0.34%, higher than 28.0% of all vulnerabilities.
- Fix: update to 1.61.15 or later.
| Package | Affected versions | Patched versions |
|---|
| litellm PyPI | < 1.61.15
| 1.61.15
|
Description
An improper authorization vulnerability exists in the main-latest version of BerriAI/litellm. When a user with the role 'internal_user_viewer' logs into the application, they are provided with an overly privileged API key. This key can be used to access all the admin functionality of the application, including endpoints such as '/users/list' and '/users/get_users'. This vulnerability allows for privilege escalation within the application, enabling any account to become a PROXY ADMIN.
NVD description
An improper authorization vulnerability exists in the main-latest version of BerriAI/litellm. When a user with the role 'internal_user_viewer' logs into the application, they are provided with an overly privileged API key. This key can be used to access all the admin functionality of the application, including endpoints such as '/users/list' and '/users/get_users'. This vulnerability allows for privilege escalation within the application, enabling any account to become a PROXY ADMIN.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free