In short
- CVE-2025-13394 is a MEDIUM (CVSS 5.4) vulnerability affecting api control plane (wso2), api manager (wso2), enterprise integrator (wso2).
- Chance of exploitation in the next 30 days (EPSS): 0.14%, higher than 3.4% of all vulnerabilities.
- Fix: update to 4.5.0.39, 4.6.0.3, 3.1.0.352, 3.2.0.456 or later.
| Package | Affected versions | Patched versions |
|---|
| api control plane | ≥ 4.5.0, < 4.5.0.39≥ 4.6.0, < 4.6.0.3
| 4.5.0.394.6.0.3
|
| api manager | ≥ 3.1.0, < 3.1.0.352≥ 3.2.0, < 3.2.0.456≥ 3.2.1, < 3.2.1.75≥ 4.0.0, < 4.0.0.376≥ 4.1.0, < 4.1.0.239≥ 4.2.0, < 4.2.0.179≥ 4.3.0, < 4.3.0.91≥ 4.4.0, < 4.4.0.55≥ 4.5.0, < 4.5.0.38≥ 4.6.0, < 4.6.0.3
| 3.1.0.3523.2.0.4563.2.1.754.0.0.3764.1.0.2394.2.0.1794.3.0.914.4.0.554.5.0.384.6.0.3
|
| enterprise integrator | ≥ 6.6.0, < 6.6.0.227
| 6.6.0.227
|
| identity server | ≥ 5.10.0, < 5.10.0.381≥ 5.11.0, < 5.11.0.428≥ 6.0.0, < 6.0.0.255≥ 6.1.0, < 6.1.0.256≥ 7.0.0, < 7.0.0.133≥ 7.1.0, < 7.1.0.41≥ 7.2.0, < 7.2.0.3
| 5.10.0.3815.11.0.4286.0.0.255
|
Description
The Ajax processor within the Carbon console fails to adequately protect state-changing operations from Cross-Site Request Forgery (CSRF) attacks. Specifically, it utilizes the HTTP GET method for these operations, and while the SameSite=Lax cookie attribute is employed for mitigation, this mechanism is bypassed as it permits cookies to be sent with cross-origin top-level navigation requests, including GET requests. This allows an attacker to trick an authenticated user's browser into unknowingly executing unintended actions.
An attacker can exploit this vulnerability to perform unauthorized state-altering requests on behalf of authenticated users. This could lead to consequences such as data modification, account changes, or other actions that could result in data compromise or loss of user control over their account. However, this attack is only feasible if the Carbon console and related services are exposed to the public internet, which is not recommended according to WSO2's security guidelines.
More vulnerabilities in api control plane
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free