In short
- CVE-2025-13425 is a LOW (CVSS 1.9) vulnerability affecting github.com/google/osv-scalibr.
- Chance of exploitation in the next 30 days (EPSS): 0.11%, higher than 1.4% of all vulnerabilities.
- Fix: update to 0.3.4 or later.
Description
A bug in the filesystem traversal fallback path causes fs/diriterate/diriterate.go:Next() to overindex an empty slice when ReadDir returns nil for an empty directory, resulting in a panic (index out of range) and an application crash (denial of service) in OSV-SCALIBR.
NVD description
A bug in the filesystem traversal fallback path causes fs/diriterate/diriterate.go:Next() to overindex an empty slice when ReadDir returns nil for an empty directory, resulting in a panic (index out of range) and an application crash (denial of service) in OSV-SCALIBR.
More vulnerabilities in github.com/google/osv-scalibr
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free