In short
- CVE-2025-13466 is a MEDIUM (CVSS 5.5) vulnerability affecting body-parser.
- Chance of exploitation in the next 30 days (EPSS): 0.39%, higher than 33.3% of all vulnerabilities.
- Fix: update to 2.2.1 or later.
| Package | Affected versions | Patched versions |
|---|
| body-parser npm | ≥ 2.2.0, < 2.2.1
| 2.2.1
|
Description
Impact
body-parser 2.2.0 is vulnerable to denial of service due to inefficient handling of URL-encoded bodies with very large numbers of parameters. An attacker can send payloads containing thousands of parameters within the default 100KB request size limit, causing elevated CPU and memory usage. This can lead to service slowdown or partial outages under sustained malicious traffic.
Patches
This issue is addressed in version 2.2.1.
NVD description
body-parser 2.2.0 is vulnerable to denial of service due to inefficient handling of URL-encoded bodies with very large numbers of parameters. An attacker can send payloads containing thousands of parameters within the default 100KB request size limit, causing elevated CPU and memory usage. This can lead to service slowdown or partial outages under sustained malicious traffic.
This issue is addressed in version 2.2.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free