In short
- CVE-2025-14009 is a HIGH (CVSS 8.8) vulnerability affecting nltk, nltk (nltk).
- Chance of exploitation in the next 30 days (EPSS): 1.0%, higher than 63.9% of all vulnerabilities.
- Fix: update to 3.9.3 or later.
| Package | Affected versions | Patched versions |
|---|
| nltk PyPI | < 3.9.3
| 3.9.3
|
| nltk | < 3.9.3
| 3.9.3
|
Description
A critical vulnerability exists in the NLTK downloader component of nltk/nltk, affecting all versions. The _unzip_iter function in nltk/downloader.py uses zipfile.extractall() without performing path validation or security checks. This allows attackers to craft malicious zip packages that, when downloaded and extracted by NLTK, can execute arbitrary code. The vulnerability arises because NLTK assumes all downloaded packages are trusted and extracts them without validation. If a malicious package contains Python files, such as init.py, these files are executed automatically upon import, leading to remote code execution. This issue can result in full system compromise, including file system access, network access, and potential persistence mechanisms.
NVD description
A critical vulnerability exists in the NLTK downloader component of nltk/nltk, affecting all versions. The _unzip_iter function in nltk/downloader.py uses zipfile.extractall() without performing path validation or security checks. This allows attackers to craft malicious zip packages that, when downloaded and extracted by NLTK, can execute arbitrary code. The vulnerability arises because NLTK assumes all downloaded packages are trusted and extracts them without validation. If a malicious package contains Python files, such as __init__.py, these files are executed automatically upon import, leading to remote code execution. This issue can result in full system compromise, including file system access, network access, and potential persistence mechanisms.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free