In short
- CVE-2025-14082 is a LOW (CVSS 2.7) vulnerability affecting org.keycloak:keycloak-services.
- Chance of exploitation in the next 30 days (EPSS): 0.35%, higher than 28.7% of all vulnerabilities.
- Fix: update to 26.5.0 or later.
Description
A flaw was found in Keycloak Admin REST (Representational State Transfer) API. This vulnerability allows information disclosure of sensitive role metadata via insufficient authorization checks on the /admin/realms/{realm}/roles endpoint.
NVD description
A flaw was found in Keycloak Admin REST (Representational State Transfer) API. This vulnerability allows information disclosure of sensitive role metadata via insufficient authorization checks on the /admin/realms/{realm}/roles endpoint.
More vulnerabilities in org.keycloak:keycloak-services
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free