In short
- CVE-2025-22223 is a MEDIUM (CVSS 5.3) vulnerability affecting org.springframework.security:spring-security-core.
- Chance of exploitation in the next 30 days (EPSS): 0.51%, higher than 43.2% of all vulnerabilities.
- Fix: update to 6.4.4 or later.
Description
Spring Security 6.4.0 - 6.4.3 may not correctly locate method security annotations on parameterized types or methods. This may cause an authorization bypass.
You are not affected if you are not using @EnableMethodSecurity, or you do not have method security annotations on parameterized types or methods, or all method security annotations are attached to target methods
NVD description
Spring Security 6.4.0 - 6.4.3 may not correctly locate method security annotations on parameterized types or methods. This may cause an authorization bypass.
You are not affected if you are not using @EnableMethodSecurity, or
you do not have method security annotations on parameterized types or methods, or all method security annotations are attached to target methods
More vulnerabilities in org.springframework.security:spring-security-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free