In short
- CVE-2025-22865 is a HIGH (CVSS 7.5) vulnerability affecting stdlib.
- Chance of exploitation in the next 30 days (EPSS): 0.61%, higher than 49.1% of all vulnerabilities.
- Fix: update to 1.24.0-rc.2 or later.
| Package | Affected versions | Patched versions |
|---|
| stdlib Go | ≥ 1.24.0-0, < 1.24.0-rc.2
| 1.24.0-rc.2
|
Description
Using ParsePKCS1PrivateKey to parse a RSA key that is missing the CRT values would panic when verifying that the key is well formed.
NVD description
Using ParsePKCS1PrivateKey to parse a RSA key that is missing the CRT values would panic when verifying that the key is well formed.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free