In short
- CVE-2025-22874 is a HIGH (CVSS 7.5) vulnerability affecting stdlib.
- Chance of exploitation in the next 30 days (EPSS): 0.37%, higher than 31.4% of all vulnerabilities.
- Fix: update to 1.24.4 or later.
| Package | Affected versions | Patched versions |
|---|
| stdlib Go | ≥ 1.24.0-0, < 1.24.4
| 1.24.4
|
Description
Calling Verify with a VerifyOptions.KeyUsages that contains ExtKeyUsageAny unintentionally disabledpolicy validation. This only affected certificate chains which contain policy graphs, which are rather uncommon.
NVD description
Calling Verify with a VerifyOptions.KeyUsages that contains ExtKeyUsageAny unintentionally disabledpolicy validation. This only affected certificate chains which contain policy graphs, which are rather uncommon.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free