In short
- CVE-2025-2304 is a CRITICAL (CVSS 9.4) vulnerability affecting camaleon_cms.
- Chance of exploitation in the next 30 days (EPSS): 0.63%, higher than 50.1% of all vulnerabilities.
- Fix: update to 2.9.1 or later.
| Package | Affected versions | Patched versions |
|---|
| camaleon_cms RubyGems | < 2.9.1
| 2.9.1
|
Description
A Privilege Escalation through a Mass Assignment exists in Camaleon CMS
When a user wishes to change his password, the 'updated_ajax' method of the UsersController is called. The vulnerability stems from the use of the dangerous permit! method, which allows all parameters to pass through without any filtering.
NVD description
A Privilege Escalation through a Mass Assignment exists in Camaleon CMS
When a user wishes to change his password, the 'updated_ajax' method of the UsersController is called. The vulnerability stems from the use of the dangerous permit! method, which allows all parameters to pass through without any filtering.
More vulnerabilities in camaleon_cms
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free