In short
- CVE-2025-23041 is a MEDIUM (CVSS 5.3) vulnerability affecting Umbraco.Forms, UmbracoForms, umbraco forms (umbraco).
- Chance of exploitation in the next 30 days (EPSS): 0.39%, higher than 32.8% of all vulnerabilities.
- Fix: update to 13.2.2, 14.1.2, 10.5.7, 8.13.16 or later.
| Package | Affected versions | Patched versions |
|---|
| Umbraco.Forms NuGet | ≥ 11.0.0-rc1, < 13.2.2≥ 14.0.0-beta001, < 14.1.2< 10.5.7
| 13.2.214.1.210.5.7
|
| UmbracoForms NuGet | < 8.13.16
| 8.13.16
|
| umbraco forms | ≥ 10.0.0, < 10.5.7≥ 13.0.0, < 13.2.2≥ 14.0.0, < 14.1.2< 8.13.15
| 10.5.713.2.214.1.28.13.15
|
Description
Impact
Character limits configured by editors for short and long answer fields are validated only client-side, not server-side.
Patches
Patched in 8.13.16, 10.5.7, 13.2.2, 14.1.2
NVD description
Umbraco.Forms is a web form framework written for the nuget ecosystem. Character limits configured by editors for short and long answer fields are validated only client-side, not server-side. This issue has been patched in versions 8.13.16, 10.5.7, 13.2.2, and 14.1.2. Users are advised to upgrade. There are no known workarounds for this issue.
More vulnerabilities in Umbraco.Forms
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free