Craft CMS Code Injection Vulnerability. Actively exploited: CISA added this vulnerability to its Known Exploited Vulnerabilities catalog on 20/02/2025. Patch affected systems as an emergency.
| Package | Affected versions | Patched versions |
|---|---|---|
| craftcms/cms | ≥ 4.0.0-RC1, < 4.13.8≥ 5.0.0-RC1, < 5.5.8 | 4.13.85.5.8 |
| craft cms | = 4.0.0= 5.0.0> 4.0.0, < 4.13.8> 5.0.0, < 5.5.8 | 4.13.85.5.8 |
This is an RCE vulnerability that affects Craft 4 and 5 installs where your security key has already been compromised.
https://craftcms.com/knowledge-base/securing-craft#keep-your-secrets-secret
Anyone running an unpatched version of Craft with a compromised security key is affected.
This has been patched in Craft 5.5.8 and 4.13.8.
If you can't update to a patched version, then rotating your security key and ensuring its privacy will help to migitgate the issue.
https://github.com/craftcms/cms/commit/e59e22b30c9dd39e5e2c7fe02c147bcbd004e603
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free