In short
- CVE-2025-24011 is a MEDIUM (CVSS 5.3) vulnerability affecting Umbraco.Cms, umbraco cms (umbraco).
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 75.9% of all vulnerabilities.
- Fix: update to 14.3.2, 15.1.2 or later.
| Package | Affected versions | Patched versions |
|---|
| Umbraco.Cms NuGet | ≥ 14.0.0, < 14.3.2≥ 15.0.0, < 15.1.2
| 14.3.215.1.2
|
| umbraco cms | ≥ 14.0.0, < 14.3.2≥ 15.0.0, < 15.1.2
| 14.3.215.1.2
|
Description
Impact
Based on an analysis of response codes and timing of Umbraco 14+ management API responses, it's possible to determine whether an account exists.
Patches
Patched in 14.3.2 and 15.1.2.
Workarounds
None available.
NVD description
Umbraco is a free and open source .NET content management system. Starting in version 14.0.0 and prior to versions 14.3.2 and 15.1.2, it's possible to determine whether an account exists based on an analysis of response codes and timing of Umbraco management API responses. Versions 14.3.2 and 15.1.2 contain a patch. No known workarounds are available.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free