In short
- CVE-2025-24374 is a MEDIUM (CVSS 4.3) vulnerability affecting twig/twig.
- Chance of exploitation in the next 30 days (EPSS): 0.29%, higher than 21.6% of all vulnerabilities.
- Fix: update to 3.19.0 or later.
| Package | Affected versions | Patched versions |
|---|
| twig/twig Packagist | ≥ 3.16.0, < 3.19.0
| 3.19.0
|
Description
When using the ?? operator, output escaping was missing for the expression on the left side of the operator.
NVD description
Twig is a template language for PHP. When using the ?? operator, output escaping was missing for the expression on the left side of the operator. This vulnerability is fixed in 3.19.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free