Apache Tomcat Path Equivalence Vulnerability. Actively exploited: CISA added this vulnerability to its Known Exploited Vulnerabilities catalog on 01/04/2025. Patch affected systems as an emergency.
| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.tomcat.embed:tomcat-embed-core | ≥ 10.1.0-M1, < 10.1.35≥ 11.0.0-M1, < 11.0.3≥ 8.5.0, ≤ 8.5.100≥ 9.0.0.M1, < 9.0.99 | 10.1.3511.0.39.0.99 |
| org.apache.tomcat:tomcat-catalina | ≥ 10.1.0-M1, < 10.1.35≥ 11.0.0-M1, < 11.0.3≥ 8.5.0, ≤ 8.5.100≥ 9.0.0.M1, < 9.0.99 | 10.1.3511.0.39.0.99 |
| tomcat | = 10.1.0= 11.0.0≥ 10.1.1, < 10.1.35≥ 11.0.1, < 11.0.3< 9.0.99 | 10.1.3511.0.39.0.99 |
Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added to uploaded files via write enabled Default Servlet in Apache Tomcat.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.2, from 10.1.0-M1 through 10.1.34, from 9.0.0.M1 through 9.0.98. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected.
If all of the following were true, a malicious user was able to view security sensitive files and/or inject content into those files: - writes enabled for the default servlet (disabled by default)
If all of the following were true, a malicious user was able to perform remote code execution:
Users are recommended to upgrade to version 11.0.3, 10.1.35 or 9.0.99, which fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free