In short
- CVE-2025-24876 is a HIGH (CVSS 8.1) vulnerability affecting @sap/approuter.
- Chance of exploitation in the next 30 days (EPSS): 0.50%, higher than 42.5% of all vulnerabilities.
- Fix: update to 16.7.2 or later.
| Package | Affected versions | Patched versions |
|---|
| @sap/approuter npm | ≥ 2.6.1, < 16.7.2
| 16.7.2
|
Description
The SAP Approuter Node.js package version v16.7.1 and before is vulnerable to Authentication bypass. When trading an authorization code, an attacker can steal the session of the victim by injecting malicious payload, causing High impact on confidentiality and integrity of the application.
NVD description
The SAP Approuter Node.js package version v16.7.1 and before is vulnerable to Authentication bypass. When trading an authorization code an attacker can steal the session of the victim by injecting malicious payload causing High impact on confidentiality and integrity of the application
More vulnerabilities in @sap/approuter
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free