| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.iotdb:node-commons | ≥ 0.10.0, < 1.3.4≥ 2.0.1-beta, < 2.0.2 | 1.3.42.0.2 |
| apache-iotdb | ≥ 0.10.0, < 1.3.4≥ 2.0.1b0, < 2.0.2 | 1.3.42.0.2 |
| iotdb | = 2.0.1≥ 0.10.0, < 1.3.4 | 1.3.4 |
Exposure of Sensitive Information to an Unauthorized Actor, Insertion of Sensitive Information into Log File vulnerability in the OpenIdAuthorizer of Apache IoTDB.
This issue affects Apache IoTDB: from 0.10.0 through 1.3.3, from 2.0.1-beta before 2.0.2.
Users are recommended to upgrade to version 1.3.4 and 2.0.2, which fix the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free