In short
- CVE-2025-2691 is a CRITICAL (CVSS 9.1) vulnerability affecting nossrf (nossrf project), nossrf.
- Chance of exploitation in the next 30 days (EPSS): 0.40%, higher than 34.3% of all vulnerabilities.
- Fix: update to 1.0.4 or later.
| Package | Affected versions | Patched versions |
|---|
| nossrf | < 1.0.4
| 1.0.4
|
| nossrf npm | < 1.0.4
| 1.0.4
|
Description
Versions of the package nossrf before 1.0.4 are vulnerable to Server-Side Request Forgery (SSRF), where an attacker can provide a hostname that resolves to a local or reserved IP address space and bypass the SSRF protection mechanism.
NVD description
Versions of the package nossrf before 1.0.4 are vulnerable to Server-Side Request Forgery (SSRF) where an attacker can provide a hostname that resolves to a local or reserved IP address space and bypass the SSRF protection mechanism.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free