In short
- CVE-2025-27097 is a HIGH (CVSS 7.5) vulnerability affecting graphql mesh (the-guild), @graphql-mesh/runtime.
- Chance of exploitation in the next 30 days (EPSS): 0.43%, higher than 37.7% of all vulnerabilities.
- Fix: update to 0.96.9 or later.
Description
When you have transforms on the root level or single source with transforms, and the client sends the same query with different variables, the initial variables are used in all following requests until the cache evicts DocumentNode.
Let's say if a token is sent via variables, the following requests will act like the same token is sent even if the following requests have different tokens.
This can cause a short memory leak but it won't grow per each request but per different operation until the cache evicts DocumentNode by LRU mechanism.
NVD description
GraphQL Mesh is a GraphQL Federation framework and gateway for both GraphQL Federation and non-GraphQL Federation subgraphs, non-GraphQL services, such as REST and gRPC, and also databases such as MongoDB, MySQL, and PostgreSQL. When a user transforms on the root level or single source with transforms, and the client sends the same query with different variables, the initial variables are used in all following requests until the cache evicts DocumentNode. If a token is sent via variables, the following requests will act like the same token is sent even if the following requests have different tokens. This can cause a short memory leak but it won't grow per each request but per different operation until the cache evicts DocumentNode by LRU mechanism.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free